Не определяется битрейт во всех AVC-файлах

Описание: Вопросы, связанные с каталогизатором фильмов All My Movies
Модераторы: datasource, Автор

Wolf_46
Пользователь
Wolf_46
Пользователь
Репутация: 0
С нами: 13 лет 6 месяцев

Сообщение #1 Wolf_46 » Чт сентября 23, 2010 3:13 am

Столкнулся с проблемой - программа не определяет битрейт файлов в х264. Не определяется как битрейт видео, так и аудио. Разрешение, длительность и пр. определяются нормально.

Пробовал как последний билд 1301, так и более старые версии. Пробовал менять библиотеку медиаинфо.длл на другую версию. При запуске любой версии (которые у меня есть) Медиаинфо через ехе битрейт определяется без проблем. Видеофайлы использовал не "кривые/битые" (как, наверное кто-то тут захотел было отметить), а, как рипаные лично мной, так и скачанные с небезызвестных ресурсов. Версии енкодера, естественно, разняться от файла к файлу.

Также пробовал поставить галку "не использовать директшоу" - не помогло...

Битрейт дивх/хвид (как и прочие параметры) определяются нормально.

Подскажите, в чем может быть проблема ?

Wolf_46
Пользователь
Wolf_46
Пользователь
Репутация: 0
С нами: 13 лет 6 месяцев

Сообщение #2 Wolf_46 » Чт сентября 23, 2010 3:52 pm

Вношу поправку - не определяет битрейт не всех AVC, а с более старой версией енкодера х264. Нашлись файлы, кодированные более свежей версией - определяет нормально. Напр не определяет версию x264 core 65 r999kMod cc51047 , но нет проблем с версией x264 core 93 r1538 bd72d46.

Повторюсь, медиаинфо, запущенная с ехе файла, определяет все без проблем.


Вернуться в «All My Movies»

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 3 гостя